PDA

View Full Version : Quicktime and Firefox


NousDefionsDoc
10-20-2006, 21:18
I can't get the plugin for Quicktime to run on Firefox to download. i have downloaded QT v 7.1.3 and the website says they should be talking automatically. But when I try to play QT in FF, it says I am missing a plugin and then it won't download the damn plugin. Any ideas?

aricbcool
10-20-2006, 23:31
Does the plugin work with IE? It may be more than just a firefox-QT issue.

--Aric

NousDefionsDoc
10-20-2006, 23:33
I can play QT on IE

aricbcool
10-20-2006, 23:37
Did you reboot after installing QT?

Also, which web browser were you using when you downloaded and installed QT?

--Aric

aricbcool
10-20-2006, 23:53
I think it may have something to do with your default web browser.

"The QuickTime installer will automatically detect your browser's plugins folder and install the plugin." - http://plugindoc.mozdev.org/windows.html

That said, if Firefox isn't your default browser, QT may have missed it in the install.

So, all you should have to do is make Firefox your default browser and reinstall QT.

Heres how to set it to default:

"Open Firefox and go to "Tools -> Options ->General -> Default Browser -> "Check Now" (or "Edit -> Preferences -> Navigator -> Set Default Browser" on Mozilla). If that doesn't work, try the following:

In Windows XP, go to "Start -> Control Panel -> Add/Remove Programs -> Set Program Access and Defaults (on the left) -> Custom". After expanding the "Custom" category, you will see Internet Explorer and other installed browsers listed under "Choose a default Web browser". Select Mozilla or Mozilla Firefox.
If that doesn't work,

In Windows Control Panel and if Windows XP is using the Control Panel "Classic View":
Click on "Folder Options -> File Types".
In Windows XP using the Control Panel "Category View":
Click on "Performance and Maintenance". Then, click on "File Types" in the left column under the heading "See Also".
Assign the following filetypes to the browser you wish to set as default:

URL:HyperText Transfer Protocol
URL:HyperText Transfer Protocol with Privacy
URL:File Transfer Protocol
HTML File
HTM File (optional)
Note that you may find the URL file types above under extension "N/A" or "(none)". "

http://kb.mozillazine.org/Setting_Your_Default_Browser#Force_Firefox_to_make _itself_the_default

If firefox is already your default browser, let me know and we'll go from there.

--Aric

NousDefionsDoc
10-21-2006, 06:51
Firefox is set as default browser. Firefox was open when I downloaded QT.

mixmatch
10-21-2006, 09:25
That definitely sounds like some sort of bug in the Firefox installation to me. I highly doubt that it is the specific movie you are trying to watch, but just in case, you can go ahead and try to view this one that I just tested and works:
http://www.ncl.ox.ac.uk/quicktime/hydrogenation.html

The only other thing I can recommend is that you verify that you have the latest version of firefox (1.5.0.7), which can be downloaded here (http://www.mozilla.com/firefox/) or through the firefox menu option "Help>Check for Updates...". An alternative to that is to try the version of firefox that is designed to run from a folder, rather than having to be installed on your PC, which is available here (http://portableapps.com/apps/internet/firefox_portable). If it views quicktime movies properly, you know for sure that it is your firefox installation that is jacked up.

aricbcool
10-21-2006, 10:39
When you installed QT, was it over an existing version of QT - an upgrade perhaps?

I remember I once had this same issue with IE. I upgraded my QT and the plugin died. Uninstalling every trace of QT and then installing the version I wanted fixed the issue.

--Aric

NousDefionsDoc
10-21-2006, 15:45
When you installed QT, was it over an existing version of QT - an upgrade perhaps?

I remember I once had this same issue with IE. I upgraded my QT and the plugin died. Uninstalling every trace of QT and then installing the version I wanted fixed the issue.

--Aric
I did that and now it works. Many thanks to all.