PDA

View Full Version : JavaScript


The Reaper
07-28-2006, 18:32
How do you turn JS on and off?

TR

aricbcool
07-28-2006, 18:49
TR,

Is this for web browsing? If so, which browser do you use? For IE, click on Tools, Internet Options..., then click on the advanced tab at the top. Scroll down to the line that says Java and unclick the option that says "Use JRE version number (requires restart)".

Regards,
Aric

jfhiller
07-28-2006, 19:28
Actually, it's confusing but Java and Javascript are two different things. If you disable Java, it will prevent Java "Applets" from functioning in web pages. A good example of a Java applet is the little interactive graph that comes up when you look at stock charts on smartmoney.com. Javascript, on the other hand, is used for things like making menus drop-down automatically on websites (there are other ways to do this, too, and there are MANY other uses for javascript, but it's a common example).

To disable Javascript in Internet Explorer, go to Tools > Internet Options > Security > Custom Level. Near the bottom of that list, you'll see a "Scripting" section. Generally, if you're disabling javascript, you just want to disable "Active Scripting". The "paste operations" function is handy for autocompleting forms and stuff and I don't think it's a great security risk, so I wouldn't think you'd need to disable that part.

You can find information on disabling javascript in other browsers and more information here:

http://javascript.about.com/library/bldisable1.htm

edited to say:
By the way, I wouldn't really recommend disabling the Java JRE that Aric mentioned, but perhaps there are reasons to do so. For that matter, I don't think javascript is THAT huge of a deal either if you keep up to date on your software patches (updates) and use basic security measures (firewall, virusscan, etc.).

The Reaper
07-28-2006, 20:07
Trying to watch the youtube videos under IE, and I am getting this message:

Hello, you either have JavaScript turned off or an old version of Macromedia's Flash Player. Click here to get the latest flash player.

Went to the Options page as directed, and all of the JS settings are set to "Enabled".

I have tried downloading the latest version of Flash, but I cannot make it go through to either save as a download, or execute.

If I use FireFox, I can view the videos, but still can't download a recent version of Flash.

Thoughts?

TR

aricbcool
07-28-2006, 20:20
TR,

What is the URL you are trying to download the new Flash from? From what you've tried above, it's probably not a JS problem.

--Aric

The Reaper
07-28-2006, 20:23
http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash

I won't take the Yahoo Toolbar with it though.

TR

aricbcool
07-28-2006, 20:28
So if you unclick the checkmark next to the yahoo toolbar and then hit "Install" what happens?

--Aric

The Reaper
07-28-2006, 20:35
So if you unclick the checkmark next to the yahoo toolbar and then hit "Install" what happens?

--Aric

Goes to this page:

http://www.adobe.com/shockwave/download/triggerpages_mmcom/flash.html

Get this:

"Important Message: You may need to click the gold bar at the top of the browser window to allow the install."

But there is no bar.

TR

aricbcool
07-28-2006, 20:47
When you first tried to install and it takes you to the second link: http://www.adobe.com/shockwave/download/triggerpages_mmcom/flash.html

Did you ever see this popup? If so, did you click yes or no...

--Aric

The Reaper
07-28-2006, 20:59
When you first tried to install and it takes you to the second link: http://www.adobe.com/shockwave/download/triggerpages_mmcom/flash.html

Did you ever see this popup? If so, did you click yes or no...

--Aric

Never saw it, never clicked on it.

TR

aricbcool
07-28-2006, 21:04
I'll be sending a PM shortly...

Also, the "Gold Bar" it was talking about isn't necessarily gold, and should look like attachment 1. The message won't be the same, but that's the general look of it.

If the second page looks the same as attachment 2, your GTG with Flash, and it's a different problem.

If you really want to be sure whether or not you have flash installed, you could do the following:

Start,
Settings,
Control Panel,
Double Click "Add/Remove Programs"
A list of programs will appear. Flash should look like Attachment 3, once you highlight it.

The Reaper
07-28-2006, 21:26
I'll be sending a PM shortly...

Also, the "Gold Bar" it was talking about isn't necessarily gold, and should look like attachment 1. The message won't be the same, but that's the general look of it.

If the second page looks the same as attachment 2, your GTG with Flash, and it's a different problem.

If you really want to be sure whether or not you have flash installed, you could do the following:

Start,
Settings,
Control Panel,
Double Click "Add/Remove Programs"
A list of programs will appear. Flash should look like Attachment 3, once you highlight it.

No attachment 1, no attachment 2, no attachment 3.

TR

aricbcool
07-28-2006, 21:44
If you go to Tools, Internet Options, Security, Custom...

What does it say under "Download Signed ActiveX Controls"?

--Aric

The Reaper
07-28-2006, 21:49
If you go to Tools, Internet Options, Security, Custom...

What does it say under "Download Signed ActiveX Controls"?

--Aric

Prompt.

TR

aricbcool
07-28-2006, 22:04
Last ditch...

Go to Tools, Internet Options, Advanced...

Uncheck the following...

Enable Install on Demand (Internet Explorer)
Enable Install on Demand (Other...)

Reboot after that and try to install Flash again.

Let me know what is different, if anything.

--Aric

The Reaper
07-28-2006, 22:07
Last ditch...

Go to Tools, Internet Options, Advanced...

Uncheck the following...

Enable Install on Demand (Internet Explorer)
Enable Install on Demand (Other...)

Reboot after that and try to install Flash again.

Let me know what is different, if anything.

--Aric

Will do before I shut down tonight. Reboot takes too long.

Thanks for the assistance.

TR

aricbcool
07-28-2006, 22:16
You're welcome. Have a good weekend, Sir.

--Aric

Martin
07-29-2006, 06:29
Sir,

Putting it on default medium security and medium privacy should enable JavaScript and everything needed to install Flash.

The following link works for Firefox, Opera, etc, it may work for IE too. Uninstall the old Flash first.
http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player.exe

HTH

M

Martin
07-31-2006, 10:09
Or temporarily enable all Active X things, go to the Flash page again and afterwards put the security settings back to defaults.

M